What’s Vulnerable › Vulnerabilities
CVE-2020-25829
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-16 · updated 2026-06-17
Description
An issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before 4.3.5. A remote attacker can cause the cached records for a given name to be updated to the Bogus DNSSEC validation state, instead of their actual DNSSEC Secure state, via a DNS ANY query. This results in a denial of service for installation that always validate (dnssec=validate), and for clients requesting validation when on-demand validation is enabled (dnssec=process).
Affected products
- openSUSE Backports Sle: 15.0-sp1, 15.0-sp2
- openSUSE Leap: 15.1, 15.2
- PowerDNS Recursor: before 4.1.18; from 4.2.0 before 4.2.5; from 4.3.0 before 4.3.5 — fixed in 4.1.18, 4.2.5, 4.3.5
How to fix
Upgrade to a fixed version: PowerDNS Recursor 4.1.18, 4.2.5, 4.3.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00036.html
- https://docs.powerdns.com/recursor/security-advisories/powerdns-advisory-2020-07.html
- https://security.gentoo.org/glsa/202012-19
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00036.html
- https://docs.powerdns.com/recursor/security-advisories/powerdns-advisory-2020-07.html
- https://security.gentoo.org/glsa/202012-19
Get alerted when CVE-2020-25829 or the next vulnerability affects your stack