What’s Vulnerable › Vulnerabilities
CVE-2020-25847: Command Injection Vulnerability in QTS and QuTS hero
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-29 · updated 2026-06-17
- Weakness: CWE-77
Description
This command injection vulnerability allows attackers to execute arbitrary commands in a compromised application. QNAP have already fixed this vulnerability in the following versions of QTS and QuTS hero.
Affected products
- QNAP QTS: before 4.5.1.1495 — fixed in 4.5.1.1495
- QNAP Systems Inc. QuTS hero: before h4.5.1.1491 — fixed in h4.5.1.1491
How to fix
Upgrade to a fixed version: QNAP QTS 4.5.1.1495; QNAP Systems Inc. QuTS hero h4.5.1.1491. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-20-20
- https://www.qnap.com/en/security-advisory/qsa-20-20
Get alerted when CVE-2020-25847 or the next vulnerability affects your stack