What’s Vulnerable › Vulnerabilities
CVE-2020-25864
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-20 · updated 2026-06-17
- Weakness: CWE-79
Description
HashiCorp Consul and Consul Enterprise up to version 1.9.4 key-value (KV) raw mode was vulnerable to cross-site scripting. Fixed in 1.9.5, 1.8.10 and 1.7.14.
Affected products
- HashiCorp Consul: before 1.7.14; from 1.8.0 before 1.8.10; from 1.9.0 before 1.9.5 — fixed in 1.7.14, 1.8.10, 1.9.5
How to fix
Upgrade to a fixed version: HashiCorp Consul 1.7.14, 1.8.10, 1.9.5. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec-2021-07-consul-api-kv-endpoint-vulnerable-to-cross-site-scripting/23368
- https://security.gentoo.org/glsa/202208-09
- https://www.hashicorp.com/blog/category/consul
- https://discuss.hashicorp.com/t/hcsec-2021-07-consul-api-kv-endpoint-vulnerable-to-cross-site-scripting/23368
- https://security.gentoo.org/glsa/202208-09
- https://www.hashicorp.com/blog/category/consul
Get alerted when CVE-2020-25864 or the next vulnerability affects your stack