What’s Vulnerable › Vulnerabilities
CVE-2020-25917
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-26 · updated 2026-06-17
- Weakness: CWE-669
Description
Stratodesk NoTouch Center before 4.4.68 is affected by: Incorrect Access Control. A low privileged user on the platform, for example a user with "helpdesk" privileges, can perform privileged operations including adding a new administrator to the platform via the easyadmin/user/submitCreateTCUser.do page.
Affected products
- Stratodesk Notouch Center: before 4.4.68 — fixed in 4.4.68
How to fix
Upgrade to a fixed version: Stratodesk Notouch Center 4.4.68. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/160652/Stratodesk-NoTouch-Center-Privilege-Escalation.html
- http://packetstormsecurity.com/files/160652/Stratodesk-NoTouch-Center-Privilege-Escalation.html
Get alerted when CVE-2020-25917 or the next vulnerability affects your stack