What’s Vulnerable › Vulnerabilities
CVE-2020-26210: Cross-Site Scripting in BookStack
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-11-03 · updated 2026-06-17
- Weakness: CWE-79
Description
In BookStack before version 0.30.4, a user with permissions to edit a page could add an attached link which would execute untrusted JavaScript code when clicked by a viewer of the page. Dangerous content may remain in the database after this update. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround, page edit permissions could be limited to only those that are trusted until you can upgrade although this will not address existing exploitation of this vulnerability. The issue is fixed in version 0.30.4.
Affected products
- bookstackapp/bookstack: before 0.30.4 — fixed in 0.30.4
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 0.30.4. Check the vendor advisory for mitigations.
References
- https://bookstackapp.com/blog/beta-release-v0-30-4/
- https://github.com/BookStackApp/BookStack/commit/349162ea139556b2d25e09e155cec84e21cc9227
- https://github.com/BookStackApp/BookStack/releases/tag/v0.30.4
- https://github.com/BookStackApp/BookStack/security/advisories/GHSA-7p2j-4h6p-cq3h
- https://bookstackapp.com/blog/beta-release-v0-30-4/
- https://github.com/BookStackApp/BookStack/commit/349162ea139556b2d25e09e155cec84e21cc9227
- https://github.com/BookStackApp/BookStack/releases/tag/v0.30.4
- https://github.com/BookStackApp/BookStack/security/advisories/GHSA-7p2j-4h6p-cq3h
Get alerted when CVE-2020-26210 or the next vulnerability affects your stack