What’s Vulnerable › Vulnerabilities
CVE-2020-26211: Cross-Site Scripting in BookStack
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-03 · updated 2026-06-17
- Weakness: CWE-79
Description
In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of `javascript:` URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround without upgrading, page edit permissions could be limited to only those that are trusted until you can upgrade although this will not address existing exploitation of this vulnerability. The issue is fixed in BookStack version 0.30.4.
Affected products
- bookstackapp/bookstack: before 0.30.4 — fixed in 0.30.4
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 0.30.4. Check the vendor advisory for mitigations.
References
- https://github.com/BookStackApp/BookStack/commit/bbd1384acbe7e52c21f89af69f2dc391c95dbf54
- https://github.com/BookStackApp/BookStack/releases/tag/v0.30.4
- https://github.com/BookStackApp/BookStack/security/advisories/GHSA-r2cf-8778-3jgp
- https://www.bookstackapp.com/blog/beta-release-v0-30-4/
- https://github.com/BookStackApp/BookStack/commit/bbd1384acbe7e52c21f89af69f2dc391c95dbf54
- https://github.com/BookStackApp/BookStack/releases/tag/v0.30.4
- https://github.com/BookStackApp/BookStack/security/advisories/GHSA-r2cf-8778-3jgp
- https://www.bookstackapp.com/blog/beta-release-v0-30-4/
Get alerted when CVE-2020-26211 or the next vulnerability affects your stack