What’s Vulnerable › Vulnerabilities
CVE-2020-26221: Stored Cross Site Scripting in touchbase.ai
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-11 · updated 2026-06-17
- Weakness: CWE-79
Description
touchbase.ai before version 2.0 is vulnerable to Cross-Site Scripting (XSS). The vulnerability allows an attacker to send malicious JavaScript code which could result in hijacking of the user's cookie/session tokens, redirecting the user to a malicious webpage and performing unintended browser action. The issue is patched in version 2.0.
Affected products
- puncsky touchbase.ai: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: puncsky touchbase.ai 2.0. Check the vendor advisory for mitigations.
References
- https://github.com/puncsky/touchbase.ai/security/advisories/GHSA-jc3v-h36h-6mx3
- https://github.com/puncsky/touchbase.ai/security/advisories/GHSA-jc3v-h36h-6mx3
Get alerted when CVE-2020-26221 or the next vulnerability affects your stack