What’s Vulnerable › Vulnerabilities
CVE-2020-26227: Cross-Site Scripting in Fluid view helpers
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 9.5.23 and 10.4.10 the system extension Fluid (typo3/cms-fluid) of the TYPO3 core is vulnerable to cross-site scripting passing user-controlled data as argument to Fluid view helpers. Update to TYPO3 versions 9.5.23 or 10.4.10 that fix the problem described.
Affected products
- typo3: from 6.2.0 before 6.2.54; from 7.6.0 before 7.6.48; from 8.7.0 before 8.7.38; from 9.0.0 before 9.5.23; from 10.0.0 before 10.4.10 — fixed in 10.4.10, 6.2.54, 7.6.48, 8.7.38, 9.5.23
How to fix
Upgrade to a fixed version: typo3 10.4.10, 6.2.54, 7.6.48, 8.7.38. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-vqqx-jw6p-q3rf
- https://typo3.org/security/advisory/typo3-core-sa-2020-010
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-vqqx-jw6p-q3rf
- https://typo3.org/security/advisory/typo3-core-sa-2020-010
Get alerted when CVE-2020-26227 or the next vulnerability affects your stack