What’s Vulnerable › Vulnerabilities
CVE-2020-26251: CORS configuration is possibly vulnerable
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-18 · updated 2026-06-17
- Weakness: CWE-346
Description
Open Zaak is a modern, open-source data- and services-layer to enable zaakgericht werken, a Dutch approach to case management. In Open Zaak before version 1.3.3 the Cross-Origin-Resource-Sharing policy in Open Zaak is currently wide open - every client is allowed. This allows evil.com to run scripts that perform AJAX calls to known Open Zaak installations, and the browser will not block these. This was intended to only apply to development machines running on localhost/127.0.0.1. Open Zaak 1.3.3 disables CORS by default, while it can be opted-in through environment variables. The vulnerability does not actually seem exploitable because: a) The session cookie has a `Same-Site: Lax` policy which prevents it from being sent along in Cross-Origin requests. b) All pages that give access to (production) data are login-protected c) `Access-Control-Allow-Credentials` is set to `false` d) CSRF checks probably block the remote origin, since they're not explicitly added to the trusted allowlist.
Affected products
- open-zaak: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: open-zaak 1.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/open-zaak/open-zaak/blob/master/CHANGELOG.rst#133-2020-12-17
- https://github.com/open-zaak/open-zaak/commit/952269269f1b629fce9c94485f83ac13f31d6c46
- https://github.com/open-zaak/open-zaak/security/advisories/GHSA-chhr-gxrg-64x7
- https://github.com/open-zaak/open-zaak/blob/master/CHANGELOG.rst#133-2020-12-17
- https://github.com/open-zaak/open-zaak/commit/952269269f1b629fce9c94485f83ac13f31d6c46
- https://github.com/open-zaak/open-zaak/security/advisories/GHSA-chhr-gxrg-64x7
Get alerted when CVE-2020-26251 or the next vulnerability affects your stack