What’s Vulnerable › Vulnerabilities
CVE-2020-26252: Layout XML RCE Vulnerability in OpenMage
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-20 · updated 2026-06-17
- Weakness: CWE-22
Description
OpenMage is a community-driven alternative to Magento CE. In OpenMage before versions 19.4.10 and 20.0.6, there is a vulnerability which enables remote code execution. In affected versions an administrator with permission to update product data to be able to store an executable file on the server and load it via layout xml. The latest OpenMage Versions up from 19.4.10 and 20.0.6 have this issue solved.
Affected products
- Openmage: before 19.4.10; from 20.0.0 before 20.0.6 — fixed in 19.4.10, 20.0.6
How to fix
Upgrade to a fixed version: Openmage 19.4.10, 20.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/0786aa48bc7b618cfe37b59f45e1da3714c533c3
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-99m6-r53j-4hh2
- https://github.com/OpenMage/magento-lts/commit/0786aa48bc7b618cfe37b59f45e1da3714c533c3
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-99m6-r53j-4hh2
Get alerted when CVE-2020-26252 or the next vulnerability affects your stack