What’s Vulnerable › Vulnerabilities
CVE-2020-26281: request smuggling in async-h1
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-21 · updated 2026-06-17
- Weakness: CWE-444
Description
async-h1 is an asynchronous HTTP/1.1 parser for Rust (crates.io). There is a request smuggling vulnerability in async-h1 before version 2.3.0. This vulnerability affects any webserver that uses async-h1 behind a reverse proxy, including all such Tide applications. If the server does not read the body of a request which is longer than some buffer length, async-h1 will attempt to read a subsequent request from the body content starting at that offset into the body. One way to exploit this vulnerability would be for an adversary to craft a request such that the body contains a request that would not be noticed by a reverse proxy, allowing it to forge forwarded/x-forwarded headers. If an application trusted the authenticity of these headers, it could be misled by the smuggled request. Another potential concern with this vulnerability is that if a reverse proxy is sending multiple http clients' requests along the same keep-alive connection, it would be possible for the smuggled request to specify a long content and capture another user's request in its body. This content could be captured in a post request to an endpoint that allows the content to be subsequently retrieved by the adversary. This has been addressed in async-h1 2.3.0 and previous versions have been yanked.
Affected products
- http-rs async-h1: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: http-rs async-h1 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/http-rs/async-h1/releases/tag/v2.3.0
- https://github.com/http-rs/async-h1/security/advisories/GHSA-4vr9-8cjf-vf9c
- https://github.com/http-rs/async-h1/releases/tag/v2.3.0
- https://github.com/http-rs/async-h1/security/advisories/GHSA-4vr9-8cjf-vf9c
Get alerted when CVE-2020-26281 or the next vulnerability affects your stack