What’s Vulnerable › Vulnerabilities
CVE-2020-26295: CMS Editor code execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-21 · updated 2026-06-17
- Weakness: CWE-22
Description
OpenMage is a community-driven alternative to Magento CE. In OpenMage before versions 19.4.10 and 20.0.5, an administrator with permission to import/export data and to edit cms pages was able to inject an executable file on the server via layout xml. The latest OpenMage Versions up from 19.4.9 and 20.0.5 have this Issue solved
Affected products
- Openmage: before 19.4.10; from 20.0.0 before 20.0.5 — fixed in 19.4.10, 20.0.5
How to fix
Upgrade to a fixed version: Openmage 19.4.10, 20.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/9cf8c0aa1d1306051a18ace08d40279dadc1fb35
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.10
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-52c6-6v3v-f3fg
- https://github.com/OpenMage/magento-lts/commit/9cf8c0aa1d1306051a18ace08d40279dadc1fb35
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.10
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-52c6-6v3v-f3fg
Get alerted when CVE-2020-26295 or the next vulnerability affects your stack