What’s Vulnerable › Vulnerabilities
CVE-2020-26296: XSS in Vega
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3
Affected products
- vega: before 5.17.3 — fixed in 5.17.3
How to fix
Upgrade to a fixed version: vega 5.17.3. Check the vendor advisory for mitigations.
References
- https://github.com/vega/vega/issues/3018
- https://github.com/vega/vega/pull/3019
- https://github.com/vega/vega/releases/tag/v5.17.3
- https://github.com/vega/vega/security/advisories/GHSA-r2qc-w64x-6j54
- https://www.npmjs.com/package/vega
- https://github.com/vega/vega/issues/3018
- https://github.com/vega/vega/pull/3019
- https://github.com/vega/vega/releases/tag/v5.17.3
- https://github.com/vega/vega/security/advisories/GHSA-r2qc-w64x-6j54
- https://www.npmjs.com/package/vega
Get alerted when CVE-2020-26296 or the next vulnerability affects your stack