What’s Vulnerable › Vulnerabilities
CVE-2020-26414
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
Description
An issue has been discovered in GitLab affecting all versions starting from 12.4. The regex used for package names is written in a way that makes execution time have quadratic growth based on the length of the malicious input string.
Affected products
- GitLab: from 12.4.0 before 13.5.6; from 13.6.0 before 13.6.4; from 13.7.0 before 13.7.2 — fixed in 13.5.6, 13.6.4, 13.7.2
How to fix
Upgrade to a fixed version: GitLab 13.5.6, 13.6.4, 13.7.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2020/CVE-2020-26414.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/270199
- https://gitlab.com/gitlab-org/cves/-/blob/master/2020/CVE-2020-26414.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/270199
Get alerted when CVE-2020-26414 or the next vulnerability affects your stack