What’s Vulnerable › Vulnerabilities
CVE-2020-26515
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-327
Description
An insufficiently protected credentials issue was discovered in Intland codeBeamer ALM 10.x through 10.1.SP4. The remember-me cookie (CB_LOGIN) issued by the application contains the encrypted user's credentials. However, due to a bug in the application code, those credentials are encrypted using a NULL encryption key.
Affected products
- PTC Codebeamer: from 10.0.0 before 10.1.0; 10.1.0, 10.1.0-sp1, 10.1.0-sp2, 10.1.0-sp3, 10.1.0-sp4 — fixed in 10.1.0
How to fix
Upgrade to a fixed version: PTC Codebeamer 10.1.0. Check the vendor advisory for mitigations.
References
- https://intland.com/codebeamer/application-lifecycle-management/
- https://www.compass-security.com/fileadmin/Research/Advisories/2021-09_CSNC-2020-010-codebeamer_ALM_Insecure-RememberMe.txt
- https://intland.com/codebeamer/application-lifecycle-management/
- https://www.compass-security.com/fileadmin/Research/Advisories/2021-09_CSNC-2020-010-codebeamer_ALM_Insecure-RememberMe.txt
Get alerted when CVE-2020-26515 or the next vulnerability affects your stack