What’s Vulnerable › Vulnerabilities
CVE-2020-26867: ARC Informatique PcVue Deserialization of Untrusted Data
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-12 · updated 2026-07-09
- Weakness: CWE-502
Description
ARC Informatique PcVue prior to version 12.0.17 is vulnerable due to the deserialization of untrusted data, which may allow an attacker to remotely execute arbitrary code on the web and mobile back-end server.
Affected products
- arcinfo PcVue: from 8.10 before 12.0.17 — fixed in 12.0.17
How to fix
Upgrade to a fixed version: arcinfo PcVue 12.0.17. Check the vendor advisory for mitigations.
References
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2020/10/09/klcert-20-015-remote-code-execution-in-arc-informatique-pcvue/
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
- https://www.pcvuesolutions.com/security
- https://www.pcvuesolutions.com/support/index.php/en/security-bulletin/1076-security-bulletin-2020-1
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2020/10/09/klcert-20-015-remote-code-execution-in-arc-informatique-pcvue/
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
- https://us-cert.cisa.gov/ics/advisories/icsa-20-308-03
Get alerted when CVE-2020-26867 or the next vulnerability affects your stack