What’s Vulnerable › Vulnerabilities
CVE-2020-26891
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-19 · updated 2026-06-17
- Weakness: CWE-79
Description
AuthRestServlet in Matrix Synapse before 1.21.0 is vulnerable to XSS due to unsafe interpolation of the session GET parameter. This allows a remote attacker to execute an XSS attack on the domain Synapse is hosted on, by supplying the victim user with a malicious URL to the /_matrix/client/r0/auth/*/fallback/web or /_matrix/client/unstable/auth/*/fallback/web Synapse endpoints.
Affected products
- matrix-org synapse: before 1.21.0 — fixed in 1.21.0
How to fix
Upgrade to a fixed version: matrix-org synapse 1.21.0. Check the vendor advisory for mitigations.
References
- https://github.com/matrix-org/synapse/pull/8444
- https://github.com/matrix-org/synapse/releases/tag/v1.21.2
- https://github.com/matrix-org/synapse/security/advisories/GHSA-3x8c-fmpc-5rmq
- https://matrix.org/blog/2020/10/15/synapse-1-21-2-released-and-security-advisory
- https://github.com/matrix-org/synapse/pull/8444
- https://github.com/matrix-org/synapse/releases/tag/v1.21.2
- https://github.com/matrix-org/synapse/security/advisories/GHSA-3x8c-fmpc-5rmq
- https://matrix.org/blog/2020/10/15/synapse-1-21-2-released-and-security-advisory
Get alerted when CVE-2020-26891 or the next vulnerability affects your stack