What’s Vulnerable › Vulnerabilities
CVE-2020-26892
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-06 · updated 2026-06-17
- Weakness: CWE-798
Description
The JWT library in NATS nats-server before 2.1.9 has Incorrect Access Control because of how expired credentials are handled.
Affected products
- Fedoraproject Fedora: 33
- nats-io nats-server: before 2.1.9 — fixed in 2.1.9
How to fix
Upgrade to a fixed version: nats-io nats-server 2.1.9. Check the vendor advisory for mitigations.
References
- https://github.com/nats-io/nats-server/commits/master
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VT67XCLIIBYRT762SVFBYFFTQFVSM3SI/
- https://www.openwall.com/lists/oss-security/2020/11/02/2
- https://github.com/nats-io/nats-server/commits/master
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VT67XCLIIBYRT762SVFBYFFTQFVSM3SI/
- https://www.openwall.com/lists/oss-security/2020/11/02/2
Get alerted when CVE-2020-26892 or the next vulnerability affects your stack