What’s Vulnerable › Vulnerabilities
CVE-2020-26893
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-16 · updated 2026-06-17
- Weakness: CWE-345
Description
An issue was discovered in ClamXAV 3 before 3.1.1. A malicious actor could use a properly signed copy of ClamXAV 2 (running with an injected malicious dylib) to communicate with ClamXAV 3's helper tool and perform privileged operations. This occurs because of inadequate client verification in the helper tool.
Affected products
- Clamxav: from 3.0.0 before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Clamxav 3.1.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/matt-clamxav/d341bd48f12a14d2147f8ce860bb36d0
- https://gist.github.com/matt-clamxav/d341bd48f12a14d2147f8ce860bb36d0
Get alerted when CVE-2020-26893 or the next vulnerability affects your stack