What’s Vulnerable › Vulnerabilities

CVE-2020-26913

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D6100 before 1.0.0.63, R7800 before 1.0.2.60, R8900 before 1.0.4.26, R9000 before 1.0.4.26, RBK20 before 2.3.0.28, RBR20 before 2.3.0.28, RBS20 before 2.3.0.28, RBK50 before 2.3.0.32, RBR50 before 2.3.0.32, RBS50 before 2.3.0.32, RBK40 before 2.3.0.28, RBR40 before 2.3.0.28, RBS40 before 2.3.0.28, SRK60 before 2.2.2.20, SRR60 before 2.2.2.20, SRS60 before 2.2.2.20, WN3000RPv2 before 1.0.0.78, WNDR4300v2 before 1.0.0.58, WNDR4500v3 before 1.0.0.58, WNR2000v5 before 1.0.0.70, XR450 before 2.3.2.40, and XR500 before 2.3.2.40.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.63; NETGEAR R7800 Firmware 1.0.2.60; NETGEAR R8900 Firmware 1.0.4.26; NETGEAR R9000 Firmware 1.0.4.26; NETGEAR Rbk20 Firmware 2.3.0.28; NETGEAR Rbk40 Firmware 2.3.0.28; NETGEAR Rbk50 Firmware 2.3.0.32; NETGEAR Rbr20 Firmware 2.3.0.28; NETGEAR Rbr50 Firmware 2.3.0.32; NETGEAR Rbs20 Firmware 2.3.0.28; NETGEAR Rbs40 Firmware 2.3.0.28; NETGEAR Rbs50 Firmware 2.3.0.32. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-26913 or the next vulnerability affects your stack