What’s Vulnerable › Vulnerabilities
CVE-2020-26935
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-10 · updated 2026-06-17
- Weakness: CWE-89
Description
An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 31, 32, 33
- openSUSE Backports Sle: 15.0, 15.0-sp1, 15.0-sp2
- openSUSE Leap: 15.1, 15.2
- phpMyAdmin: from 4.9.0 before 4.9.6; from 5.0.0 before 5.0.3 — fixed in 4.9.6, 5.0.3
How to fix
Upgrade to a fixed version: phpMyAdmin 4.9.6, 5.0.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00005.html
- https://advisory.checkmarx.net/advisory/CX-2020-4281
- https://lists.debian.org/debian-lts-announce/2020/10/msg00024.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FHST4E5IJG7IKZTTW3R6MEZPVHJZ472K/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PXK37YEHSDYCIPQSYEMN2OFTP2ZLM7DO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNLGHVDNAEZEGRTUESSSQFM7MZTHIDQ5/
- https://security.gentoo.org/glsa/202101-35
- https://www.phpmyadmin.net/security/PMASA-2020-6/
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00005.html
- https://advisory.checkmarx.net/advisory/CX-2020-4281
Get alerted when CVE-2020-26935 or the next vulnerability affects your stack