What’s Vulnerable › Vulnerabilities
CVE-2020-26971
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-07 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain blit values provided by the user were not properly constrained leading to a heap buffer overflow on some video drivers. This vulnerability affects Firefox < 84, Thunderbird < 78.6, and Firefox ESR < 78.6.
Affected products
- Mozilla Firefox: before 84.0 — fixed in 84.0
- Mozilla Firefox ESR: before 78.6.0 — fixed in 78.6.0
- Mozilla Thunderbird: before 78.6.0 — fixed in 78.6.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 84.0; Mozilla Firefox ESR 78.6.0; Mozilla Thunderbird 78.6.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1663466
- https://www.mozilla.org/security/advisories/mfsa2020-54/
- https://www.mozilla.org/security/advisories/mfsa2020-55/
- https://www.mozilla.org/security/advisories/mfsa2020-56/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1663466
- https://www.mozilla.org/security/advisories/mfsa2020-54/
- https://www.mozilla.org/security/advisories/mfsa2020-55/
- https://www.mozilla.org/security/advisories/mfsa2020-56/
Get alerted when CVE-2020-26971 or the next vulnerability affects your stack