What’s Vulnerable › Vulnerabilities
CVE-2020-26976
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-07 · updated 2026-06-17
Description
When a HTTPS pages was embedded in a HTTP page, and there was a service worker registered for the former, the service worker could have intercepted the request for the secure page despite the iframe not being a secure context due to the (insecure) framing. This vulnerability affects Firefox < 84.
Affected products
- Debian Linux: 9.0, 10.0
- Mozilla Firefox: before 84.0 — fixed in 84.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 84.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1674343
- https://lists.debian.org/debian-lts-announce/2021/02/msg00001.html
- https://lists.debian.org/debian-lts-announce/2021/02/msg00002.html
- https://security.gentoo.org/glsa/202102-02
- https://www.debian.org/security/2021/dsa-4840
- https://www.debian.org/security/2021/dsa-4842
- https://www.mozilla.org/security/advisories/mfsa2020-54/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1674343
- https://lists.debian.org/debian-lts-announce/2021/02/msg00001.html
- https://lists.debian.org/debian-lts-announce/2021/02/msg00002.html
- https://security.gentoo.org/glsa/202102-02
- https://www.debian.org/security/2021/dsa-4840
Get alerted when CVE-2020-26976 or the next vulnerability affects your stack