What’s Vulnerable › Vulnerabilities

CVE-2020-27350: apt integer wraparound

Description

APT had several integer overflows and underflows while parsing .deb packages, aka GHSL-2020-168 GHSL-2020-169, in files apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc. This issue affects: apt 1.2.32ubuntu0 versions prior to 1.2.32ubuntu0.2; 1.6.12ubuntu0 versions prior to 1.6.12ubuntu0.2; 2.0.2ubuntu0 versions prior to 2.0.2ubuntu0.2; 2.1.10ubuntu0 versions prior to 2.1.10ubuntu0.1;

Affected products

How to fix

Upgrade to a fixed version: Debian Advanced Package Tool 1.2.32ubuntu0.2, 1.6.12ubuntu0.2, 1.8.2.2, 2.0.2ubuntu0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-27350 or the next vulnerability affects your stack