What’s Vulnerable › Vulnerabilities
CVE-2020-27488
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-13 · updated 2026-06-17
- Weakness: CWE-287
Description
Loxone Miniserver devices with firmware before 11.1 (aka 11.1.9.3) are unable to use an authentication method that is based on the "signature of the update package." Therefore, these devices (or attackers who are spoofing these devices) can continue to use an unauthenticated cloud service for an indeterminate time period (possibly forever). Once an individual device's firmware is updated, and authentication occurs once, the cloud service recategorizes the device so that authentication is subsequently always required, and spoofing cannot occur.
Affected products
- Loxone Miniserver Gen 1 Firmware: before 11.1.9.3 — fixed in 11.1.9.3
How to fix
Upgrade to a fixed version: Loxone Miniserver Gen 1 Firmware 11.1.9.3. Check the vendor advisory for mitigations.
References
- https://iot-lab-fh-ooe.github.io/loxone_clouddns_schwachstelle/
- https://iot-lab-fh-ooe.github.io/loxone_clouddns_vulnerability/
- https://www.loxone.com/dede/sicherheit-cloud-dns/
- https://www.loxone.com/enen/security-cloud-dns/
- https://iot-lab-fh-ooe.github.io/loxone_clouddns_schwachstelle/
- https://iot-lab-fh-ooe.github.io/loxone_clouddns_vulnerability/
- https://www.loxone.com/dede/sicherheit-cloud-dns/
- https://www.loxone.com/enen/security-cloud-dns/
Get alerted when CVE-2020-27488 or the next vulnerability affects your stack