What’s Vulnerable › Vulnerabilities
CVE-2020-27507
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-120
Description
The Kamailio SIP before 5.5.0 server mishandles INVITE requests with duplicated fields and overlength tag, leading to a buffer overflow that crashes the server or possibly have unspecified other impact.
Affected products
- Kamailio: before 5.5.0 — fixed in 5.5.0
How to fix
Upgrade to a fixed version: Kamailio 5.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/kamailio/kamailio/commit/ada3701d22b1fd579f06b4f54fa695fa988e685f
- https://github.com/kamailio/kamailio/issues/2503
- https://lists.debian.org/debian-lts-announce/2023/05/msg00030.html
- https://github.com/kamailio/kamailio/commit/ada3701d22b1fd579f06b4f54fa695fa988e685f
- https://github.com/kamailio/kamailio/issues/2503
- https://lists.debian.org/debian-lts-announce/2023/05/msg00030.html
Get alerted when CVE-2020-27507 or the next vulnerability affects your stack