What’s Vulnerable › Vulnerabilities
CVE-2020-27619
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-22 · updated 2026-10-08
Description
In Python 3 through 3.9.0, the Lib/test/multibytecodec_support.py CJK codec tests call eval() on content retrieved via HTTP.
Affected products
- Fedoraproject Fedora: 33, 34
- Oracle Communications Cloud Native Core Network Function Cloud Native Environment: 22.2.0
- Python: from 3.0.0 before 3.6.13; from 3.7.0 before 3.7.10; from 3.8.0 before 3.8.7; from 3.9.0 before 3.9.1 — fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1
How to fix
Upgrade to a fixed version: Python 3.6.13, 3.7.10, 3.8.7, 3.9.1. Check the vendor advisory for mitigations.
References
- https://bugs.python.org/issue41944
- https://github.com/python/cpython/commit/2ef5caa58febc8968e670e39e3d37cf8eef3cab8
- https://github.com/python/cpython/commit/43e523103886af66d6c27cd72431b5d9d14cd2a9
- https://github.com/python/cpython/commit/6c6c256df3636ff6f6136820afaefa5a10a3ac33
- https://github.com/python/cpython/commit/b664a1df4ee71d3760ab937653b10997081b1794
- https://github.com/python/cpython/commit/e912e945f2960029d039d3390ea08835ad39374b
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772%40%3Cdev.mina.apache.org%3E
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RSLQD5CCM75IZGAMBDGUZEATYU5YSGJ7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGIY6I4YS3WOXAK4SXKIEOC2G4VZKIR7/
- https://security.gentoo.org/glsa/202402-04
Get alerted when CVE-2020-27619 or the next vulnerability affects your stack