What’s Vulnerable › Vulnerabilities
CVE-2020-27687
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-18 · updated 2026-06-17
- Weakness: CWE-20
Description
ThingsBoard before v3.2 is vulnerable to Host header injection in password-reset emails. This allows an attacker to send malicious links in password-reset emails to victims, pointing to an attacker-controlled server. Lack of validation of the Host header allows this to happen.
Affected products
- ThingsBoard: before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: ThingsBoard 3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/vin01/26a8bb13233acd9425e7575a7ad4c936
- https://github.com/thingsboard/thingsboard/commits/master
- https://gist.github.com/vin01/26a8bb13233acd9425e7575a7ad4c936
- https://github.com/thingsboard/thingsboard/commits/master
Get alerted when CVE-2020-27687 or the next vulnerability affects your stack