What’s Vulnerable › Vulnerabilities
CVE-2020-27730
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-11 · updated 2026-06-17
- Weakness: CWE-22
Description
In versions 3.0.0-3.9.0, 2.0.0-2.9.0, and 1.0.1, the NGINX Controller Agent does not use absolute paths when calling system utilities.
Affected products
- NGINX Controller: from 2.0.0 through 2.9.0; from 3.0.0 before 3.10.0; 1.0.1 — fixed in 3.10.0
- NetApp Cloud Backup: all versions
How to fix
Upgrade to a fixed version: NGINX Controller 3.10.0. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20210115-0004/
- https://support.f5.com/csp/article/K43530108
- https://security.netapp.com/advisory/ntap-20210115-0004/
- https://support.f5.com/csp/article/K43530108
Get alerted when CVE-2020-27730 or the next vulnerability affects your stack