What’s Vulnerable › Vulnerabilities
CVE-2020-27745
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-27 · updated 2026-06-17
- Weakness: CWE-120
Description
Slurm before 19.05.8 and 20.x before 20.02.6 has an RPC Buffer Overflow in the PMIx MPI plugin.
Affected products
- Debian Linux: 9.0, 10.0
- SchedMD Slurm: before 19.05.8; from 20.0.0 before 20.02.6 — fixed in 19.05.8, 20.02.6
How to fix
Upgrade to a fixed version: SchedMD Slurm 19.05.8, 20.02.6. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2022/01/msg00011.html
- https://www.debian.org/security/2021/dsa-4841
- https://www.schedmd.com/news.php
- https://lists.debian.org/debian-lts-announce/2022/01/msg00011.html
- https://www.debian.org/security/2021/dsa-4841
- https://www.schedmd.com/news.php
Get alerted when CVE-2020-27745 or the next vulnerability affects your stack