What’s Vulnerable › Vulnerabilities
CVE-2020-27754
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-08 · updated 2026-06-17
- Weakness: CWE-190
Description
In IntensityCompare() of /magick/quantize.c, there are calls to PixelPacketIntensity() which could return overflowed values to the caller when ImageMagick processes a crafted input file. To mitigate this, the patch introduces and uses the ConstrainPixelIntensity() function, which forces the pixel intensities to be within the proper bounds in the event of an overflow. This flaw affects ImageMagick versions prior to 6.9.10-69 and 7.0.8-69.
Affected products
- Debian Linux: 9.0
- ImageMagick: before 6.9.10-69; from 7.0.8 before 7.0.8-69 — fixed in 6.9.10-69, 7.0.8-69
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-69, 7.0.8-69. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1894231
- https://lists.debian.org/debian-lts-announce/2021/03/msg00030.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1894231
- https://lists.debian.org/debian-lts-announce/2021/03/msg00030.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
Get alerted when CVE-2020-27754 or the next vulnerability affects your stack