What’s Vulnerable › Vulnerabilities
CVE-2020-27759
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-03 · updated 2026-06-17
- Weakness: CWE-190
Description
In IntensityCompare() of /MagickCore/quantize.c, a double value was being casted to int and returned, which in some cases caused a value outside the range of type `int` to be returned. The flaw could be triggered by a crafted input file under certain conditions when processed by ImageMagick. Red Hat Product Security marked this as Low severity because although it could potentially lead to an impact to application availability, no specific impact was shown in this case. This flaw affects ImageMagick versions prior to 7.0.8-68.
Affected products
- Debian Linux: 9.0
- ImageMagick: before 6.9.10-68; from 7.0.0-0 before 7.0.8-68 — fixed in 6.9.10-68, 7.0.8-68
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-68, 7.0.8-68. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1894238
- https://lists.debian.org/debian-lts-announce/2021/03/msg00030.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1894238
- https://lists.debian.org/debian-lts-announce/2021/03/msg00030.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
Get alerted when CVE-2020-27759 or the next vulnerability affects your stack