What’s Vulnerable › Vulnerabilities
CVE-2020-27770
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-04 · updated 2026-06-17
- Weakness: CWE-190
Description
Due to a missing check for 0 value of `replace_extent`, it is possible for offset `p` to overflow in SubstituteString(), causing potential impact to application availability. This could be triggered by a crafted input file that is processed by ImageMagick. This flaw affects ImageMagick versions prior to 7.0.8-68.
Affected products
- Debian Linux: 9.0
- ImageMagick: before 6.9.10-68; from 7.0.0-0 before 7.0.8-68 — fixed in 6.9.10-68, 7.0.8-68
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-68, 7.0.8-68. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1894691
- https://lists.debian.org/debian-lts-announce/2021/03/msg00030.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1894691
- https://lists.debian.org/debian-lts-announce/2021/03/msg00030.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
Get alerted when CVE-2020-27770 or the next vulnerability affects your stack