What’s Vulnerable › Vulnerabilities
CVE-2020-27778
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-03 · updated 2026-06-17
- Weakness: CWE-824
Description
A flaw was found in Poppler in the way certain PDF files were converted into HTML. A remote attacker could exploit this flaw by providing a malicious PDF file that, when processed by the 'pdftohtml' program, would crash the application causing a denial of service.
Affected products
- Debian Linux: 10.0
- poppler: before 0.76.0 — fixed in 0.76.0
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: poppler 0.76.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1900712
- https://lists.debian.org/debian-lts-announce/2022/09/msg00030.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1900712
- https://lists.debian.org/debian-lts-announce/2022/09/msg00030.html
Get alerted when CVE-2020-27778 or the next vulnerability affects your stack