What’s Vulnerable › Vulnerabilities
CVE-2020-27813
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-02 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow vulnerability exists with the length of websocket frames received via a websocket connection. An attacker would use this flaw to cause a denial of service attack on an HTTP Server allowing websocket connections.
Affected products
- Debian Linux: 9.0
- Gorillatoolkit Websocket: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Gorillatoolkit Websocket 1.4.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1902111
- https://github.com/gorilla/websocket/security/advisories/GHSA-jf24-p9p9-4rjh
- https://lists.debian.org/debian-lts-announce/2021/01/msg00008.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00012.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1902111
- https://github.com/gorilla/websocket/security/advisories/GHSA-jf24-p9p9-4rjh
- https://lists.debian.org/debian-lts-announce/2021/01/msg00008.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00012.html
Get alerted when CVE-2020-27813 or the next vulnerability affects your stack