What’s Vulnerable › Vulnerabilities
CVE-2020-27821
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-08 · updated 2026-06-17
- Weakness: CWE-787
Description
A flaw was found in the memory management API of QEMU during the initialization of a memory region cache. This issue could lead to an out-of-bounds write access to the MSI-X table while performing MMIO operations. A guest user may abuse this flaw to crash the QEMU process on the host, resulting in a denial of service. This flaw affects QEMU versions prior to 5.2.0.
Affected products
- Debian Linux: 10.0
- QEMU: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: QEMU 5.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2020/12/16/6
- https://bugzilla.redhat.com/show_bug.cgi?id=1902651
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://security.netapp.com/advisory/ntap-20210115-0006/
- http://www.openwall.com/lists/oss-security/2020/12/16/6
- https://bugzilla.redhat.com/show_bug.cgi?id=1902651
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://security.netapp.com/advisory/ntap-20210115-0006/
Get alerted when CVE-2020-27821 or the next vulnerability affects your stack