What’s Vulnerable › Vulnerabilities
CVE-2020-27847
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-28 · updated 2026-06-17
- Weakness: CWE-228
Description
A vulnerability exists in the SAML connector of the github.com/dexidp/dex library used to process SAML Signature Validation. This flaw allows an attacker to bypass SAML authentication. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. This flaw affects dex versions before 2.27.0.
Affected products
- dexidp dex: before 2.27.0 — fixed in 2.27.0
How to fix
Upgrade to a fixed version: dexidp dex 2.27.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1907732
- https://github.com/dexidp/dex/security/advisories/GHSA-m9hp-7r99-94h5
- https://mattermost.com/blog/coordinated-disclosure-go-xml-vulnerabilities/
- https://bugzilla.redhat.com/show_bug.cgi?id=1907732
- https://github.com/dexidp/dex/security/advisories/GHSA-m9hp-7r99-94h5
- https://mattermost.com/blog/coordinated-disclosure-go-xml-vulnerabilities/
Get alerted when CVE-2020-27847 or the next vulnerability affects your stack