What’s Vulnerable › Vulnerabilities
CVE-2020-27848
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-30 · updated 2026-06-17
- Weakness: CWE-89
Description
dotCMS before 20.10.1 allows SQL injection, as demonstrated by the /api/v1/containers orderby parameter. The PaginatorOrdered classes that are used to paginate results of a REST endpoints do not sanitize the orderBy parameter and in some cases it is vulnerable to SQL injection attacks. A user must be an authenticated manager in the dotCMS system to exploit this vulnerability.
Affected products
- dotCMS core: before 20.10.1 — fixed in 20.10.1
How to fix
Upgrade to a fixed version: dotCMS core 20.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/dotCMS/core/compare/v5.3.8.1...v20.10.1
- https://github.com/dotCMS/core/issues/19500
- https://github.com/dotCMS/core/compare/v5.3.8.1...v20.10.1
- https://github.com/dotCMS/core/issues/19500
Get alerted when CVE-2020-27848 or the next vulnerability affects your stack