What’s Vulnerable › Vulnerabilities
CVE-2020-27853
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-27 · updated 2026-06-17
- Weakness: CWE-134
Description
Wire before 2020-10-16 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a format string. This affects Wire AVS (Audio, Video, and Signaling) 5.3 through 6.x before 6.4, the Wire Secure Messenger application before 3.49.918 for Android, and the Wire Secure Messenger application before 3.61 for iOS. This occurs via the value parameter to sdp_media_set_lattr in peerflow/sdp.c.
Affected products
- wireapp wire-ios: before 3.21.2936; before 3.21.3932; before 3.21.3959 — fixed in 3.21.2936, 3.21.3932, 3.21.3959
- Wire - Audio, Video, And Signaling: from 5.3 before 6.4 — fixed in 6.4
- Wire Secure Messenger: before 3.49.918; before 3.61 — fixed in 3.49.918, 3.61
How to fix
Upgrade to a fixed version: wireapp wire-ios 3.21.2936, 3.21.3932, 3.21.3959; Wire - Audio, Video, And Signaling 6.4; Wire Secure Messenger 3.49.918, 3.61. Check the vendor advisory for mitigations.
References
- http://github.security.telekom.com/2020/11/wire-secure-messenger-format-string-vulnerability.html
- https://github.com/wireapp/wire-audio-video-signaling/issues/23#issuecomment-710075689
- http://github.security.telekom.com/2020/11/wire-secure-messenger-format-string-vulnerability.html
- https://github.com/wireapp/wire-audio-video-signaling/issues/23#issuecomment-710075689
Get alerted when CVE-2020-27853 or the next vulnerability affects your stack