What’s Vulnerable › Vulnerabilities
CVE-2020-27978
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-28 · updated 2026-06-17
- Weakness: CWE-770
Description
Shibboleth Identify Provider 3.x before 3.4.6 has a denial of service flaw. A remote unauthenticated attacker can cause a login flow to trigger Java heap exhaustion due to the creation of objects in the Java Servlet container session.
Affected products
- Shibboleth Identity Provider: from 3.0.0 before 3.4.6 — fixed in 3.4.6
How to fix
Upgrade to a fixed version: Shibboleth Identity Provider 3.4.6. Check the vendor advisory for mitigations.
References
- https://shibboleth.net/community/advisories/secadv_20191002.txt
- https://shibboleth.net/community/advisories/secadv_20191002.txt
Get alerted when CVE-2020-27978 or the next vulnerability affects your stack