What’s Vulnerable › Vulnerabilities
CVE-2020-28008
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-269
Description
Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root in the spool directory (owned by a non-root user), an attacker can write to a /var/spool/exim4/input spool header file, in which a crafted recipient address can indirectly lead to command execution.
Affected products
- Exim: from 4.00 before 4.94.2 — fixed in 4.94.2
How to fix
Upgrade to a fixed version: Exim 4.94.2. Check the vendor advisory for mitigations.
References
- https://www.exim.org/static/doc/security/CVE-2020-qualys/CVE-2020-28008-SPDIR.txt
- https://www.exim.org/static/doc/security/CVE-2020-qualys/CVE-2020-28008-SPDIR.txt
Get alerted when CVE-2020-28008 or the next vulnerability affects your stack