What’s Vulnerable › Vulnerabilities
CVE-2020-28339
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-11-07 · updated 2026-06-17
- Weakness: CWE-502
Description
The usc-e-shop (aka Collne Welcart e-Commerce) plugin before 1.9.36 for WordPress allows Object Injection because of usces_unserialize. There is not a complete POP chain.
Affected products
- Welcart e-Commerce: before 1.9.36 — fixed in 1.9.36
How to fix
Upgrade to a fixed version: Welcart e-Commerce 1.9.36. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/usc-e-shop/#developers
- https://www.wordfence.com/blog/2020/11/object-injection-vulnerability-in-welcart-e-commerce-plugin/
- https://wordpress.org/plugins/usc-e-shop/#developers
- https://www.wordfence.com/blog/2020/11/object-injection-vulnerability-in-welcart-e-commerce-plugin/
Get alerted when CVE-2020-28339 or the next vulnerability affects your stack