What’s Vulnerable › Vulnerabilities
CVE-2020-28446: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-77
Description
The package ntesseract before 0.2.9 are vulnerable to Command Injection via lib/tesseract.js.
Affected products
- ntesseract: before 0.2.9 — fixed in 0.2.9
How to fix
Upgrade to a fixed version: ntesseract 0.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/taoyuan/ntesseract/commit/fcbc36f381798b4362179c0cdf9961b437c7b619
- https://security.snyk.io/vuln/SNYK-JS-NTESSERACT-1050982
- https://github.com/taoyuan/ntesseract/commit/fcbc36f381798b4362179c0cdf9961b437c7b619
- https://security.snyk.io/vuln/SNYK-JS-NTESSERACT-1050982
Get alerted when CVE-2020-28446 or the next vulnerability affects your stack