What’s Vulnerable › Vulnerabilities
CVE-2020-28456: Cross-site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The package s-cart/core before 4.4 are vulnerable to Cross-site Scripting (XSS) via the admin panel.
Affected products
- s-cart/core: before 4.4 — fixed in 4.4
How to fix
Upgrade to a fixed version: s-cart/core 4.4. Check the vendor advisory for mitigations.
References
- https://github.com/s-cart/core/commit/f4b2811293063a3a2bb497b2512d8a18bd202219
- https://github.com/s-cart/s-cart/issues/52
- https://github.com/s-cart/s-cart/releases/tag/v4.4
- https://snyk.io/vuln/SNYK-PHP-SCARTCORE-1047609
- https://github.com/s-cart/core/commit/f4b2811293063a3a2bb497b2512d8a18bd202219
- https://github.com/s-cart/s-cart/issues/52
- https://github.com/s-cart/s-cart/releases/tag/v4.4
- https://snyk.io/vuln/SNYK-PHP-SCARTCORE-1047609
Get alerted when CVE-2020-28456 or the next vulnerability affects your stack