What’s Vulnerable › Vulnerabilities
CVE-2020-28457: Cross-site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-15 · updated 2026-06-17
- Weakness: CWE-79
Description
This affects the package s-cart/core before 4.4. The search functionality of the admin dashboard in core/src/Admin/Controllers/AdminOrderController.phpindex is vulnerable to XSS.
Affected products
- s-cart/core: before 4.4 — fixed in 4.4
How to fix
Upgrade to a fixed version: s-cart/core 4.4. Check the vendor advisory for mitigations.
References
- https://github.com/s-cart/s-cart/commit/4406d407ad363ee7e4795ee290c9d2430b0413f8
- https://github.com/s-cart/s-cart/issues/51
- https://github.com/s-cart/s-cart/releases/tag/v4.4
- https://snyk.io/vuln/SNYK-PHP-SCARTCORE-1047342
- https://github.com/s-cart/s-cart/commit/4406d407ad363ee7e4795ee290c9d2430b0413f8
- https://github.com/s-cart/s-cart/issues/51
- https://github.com/s-cart/s-cart/releases/tag/v4.4
- https://snyk.io/vuln/SNYK-PHP-SCARTCORE-1047342
Get alerted when CVE-2020-28457 or the next vulnerability affects your stack