What’s Vulnerable › Vulnerabilities
CVE-2020-28468: Improper Control of Generation of Code ('Code Injection')
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-08 · updated 2026-06-17
- Weakness: CWE-74
Description
This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.
Affected products
- pwntools: before 4.3.1 — fixed in 4.3.1
How to fix
Upgrade to a fixed version: pwntools 4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/Gallopsled/pwntools/issues/1427
- https://github.com/Gallopsled/pwntools/pull/1732
- https://snyk.io/vuln/SNYK-PYTHON-PWNTOOLS-1047345
- https://github.com/Gallopsled/pwntools/issues/1427
- https://github.com/Gallopsled/pwntools/pull/1732
- https://snyk.io/vuln/SNYK-PYTHON-PWNTOOLS-1047345
Get alerted when CVE-2020-28468 or the next vulnerability affects your stack