What’s Vulnerable › Vulnerabilities
CVE-2020-28470: Cross-site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-14 · updated 2026-06-17
- Weakness: CWE-79
Description
This affects the package @scullyio/scully before 1.0.9. The transfer state is serialised with the JSON.stringify() function and then written into the HTML page.
Affected products
- @scullyio/scully: before 1.0.9 — fixed in 1.0.9
How to fix
Upgrade to a fixed version: @scullyio/scully 1.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/scullyio/scully/pull/1182
- https://snyk.io/vuln/SNYK-JS-SCULLYIOSCULLY-1055829
- https://github.com/scullyio/scully/pull/1182
- https://snyk.io/vuln/SNYK-JS-SCULLYIOSCULLY-1055829
Get alerted when CVE-2020-28470 or the next vulnerability affects your stack