What’s Vulnerable › Vulnerabilities
CVE-2020-28481: Insecure Defaults
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-19 · updated 2026-06-17
- Weakness: CWE-346
Description
The package socket.io before 2.4.0 are vulnerable to Insecure Defaults due to CORS Misconfiguration. All domains are whitelisted by default.
Affected products
- socketio socket.io: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: socketio socket.io 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/socketio/socket.io/issues/3671
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-1056358
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1056357
- https://snyk.io/vuln/SNYK-JS-SOCKETIO-1024859
- https://github.com/socketio/socket.io/issues/3671
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-1056358
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1056357
- https://snyk.io/vuln/SNYK-JS-SOCKETIO-1024859
Get alerted when CVE-2020-28481 or the next vulnerability affects your stack