What’s Vulnerable › Vulnerabilities
CVE-2020-28487: Cross-site Scripting (XSS)
- Severity: medium (CVSS 6.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-22 · updated 2026-06-17
- Weakness: CWE-79
Description
This affects the package vis-timeline before 7.4.4. An attacker with the ability to control the items of a Timeline element can inject additional script code into the generated application.
Affected products
- vis-timeline: before 7.4.4 — fixed in 7.4.4
How to fix
Upgrade to a fixed version: vis-timeline 7.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/visjs/vis-timeline/issues/838
- https://github.com/visjs/vis-timeline/pull/840
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBVISJS-1063502
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1063501
- https://snyk.io/vuln/SNYK-JS-VISTIMELINE-1063500
- https://github.com/visjs/vis-timeline/issues/838
- https://github.com/visjs/vis-timeline/pull/840
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBVISJS-1063502
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1063501
- https://snyk.io/vuln/SNYK-JS-VISTIMELINE-1063500
Get alerted when CVE-2020-28487 or the next vulnerability affects your stack