What’s Vulnerable › Vulnerabilities

CVE-2020-28500: Regular Expression Denial of Service (ReDoS)

Description

Lodash versions prior to 4.17.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the toNumber, trim and trimEnd functions.

Affected products

How to fix

Upgrade to a fixed version: lodash 4.17.21; Oracle Corporation JD Edwards EnterpriseOne Tools 9.2.6.1; Siemens SINEC INS 1.0; Npm Lodash 4.17.21; Npm Lodash-Es 4.17.21; Rubygems Lodash-Rails 4.17.21. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-28500 or the next vulnerability affects your stack